Randomly unable to edit JavaScript and Static Data

Summary
Unable to open JavaScript edit-window (i.e. unable to edit JavaScript-nodes) in old projects.

Steps To Reproduce
Update to latest Noodl (1.3.0). Open a project created prior to latest update. Click “Edit” on any JavaScript node.

Expected Result
JavaScript code is displayed in newly opened window.

Actual Result
Nothing.

Solution Attempts

  • Tried creating a new project and importing all nodes, unable to edit.
  • Tried creating new JavaScript-nodes in old project, still unable to edit.

Partly Solved

  • Tried creating a new project and importing a small amount of nodes, this time I was able to edit JavaScript-nodes. However, importing all nodes from my old project caused all JavaScript-nodes to lock up again.

Update
I used the strategy described in Partly Solved above where I created a fresh project and imported some nodes into it. After working for a number of hours the JavaScript-nodes in the fresh project suddenly became un-editable again. Restarting seemed to solve the issue this time.

Hey!

I can’t seem to reproduce this, could you perhaps send a simple project where the JS is not working and I can take a look at it!

Thanks!

What platform are you on? I tested your project on windows and mac with 1.3.0 and I can edit all Javascript nodes. Very strange…

The plot thickens! I’m on mac, 10.13.1. I also recently ran into problems trying to edit a Static Data-node, this time a restart did not solve the issue. Not sure what causes this “lock-up” state or what releases it. It seems to happen randomly for a project. When it does, I’m unable to edit Static Data or JavaScript-nodes for that specific project. During this time I can still open up other projects where the editing works.

This may be something, it seems that I’m unable to edit JavaScript/Static Data when the port of a node in the project is changed/removed (as shown by the dotted line between ports). Removing these broken connectors allows editing again. Not sure how/why/if this is the same reason why I originally couldn’t edit the JavaScript in the project I uploaded (which contains no broken port links).

Thank you very much! Bug is fixed and update will be delivered soon.

-Mikael

1 Like